Question

Rocketchat unable to pull up webpage after enabling ssl

Posted November 30, 2020 260 views
DigitalOcean 1-Click Apps Marketplace

I ran this command to enable ssl and now I can not get the page page up I tried https://ipaddress and https://ipaddress:3000. What am I missing?

rocketchatctl configure --lets-encrypt --root-url=https://chat.website.com --letsencrypt-email=itdept@website.com
edited by bobbyiliev

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Hello,

What errors do you get when you visit the IP address via https?

Also is the Rocketchat instance accessible via your https://chat.website.com domain name directly?

Regards,
Bobby

Hello there,

Can you confirm if node is listening on port 3000? I’ve just spun up a droplet using the marketplace app.

You can check if node is listening on the port using the netstat command:

  • netstat -plunta | grep 3000

The output must be:

netstat -plunta | grep 3000
tcp        0      0 0.0.0.0:3000            0.0.0.0:*               LISTEN      1043/node
tcp        0      0 :3000    :62373     ESTABLISHED 1043/node
tcp        0      0 :3000    :62370     ESTABLISHED 1043/node
tcp        0      0 :3000    :62372     ESTABLISHED 1043/node
tcp        0      0 :3000    :62376     ESTABLISHED 1043/node
tcp        0      0 :3000    :62375     ESTABLISHED 1043/node
tcp        0      0 :3000    :62371     ESTABLISHED 1043/node
tcp        0    128 :3000    :62374     ESTABLISHED 1043/node

Also, have you made any custom changes after the initial droplet deployment? I’ve completed the installation and then used the same option to enable HTTPS:

  • rocketchatctl configure --lets-encrypt --root-url=https://chat.yourcompany.com --letsencrypt-email=admin@yourcompany.com

Regards,
Alex