Root password reset email not working

March 26, 2014 11.7k views
I'm having issues with logging in via SSH with Putty. I have tried resetting the root password, and a new password has been sent to my email address. However, when I try to login with "root" and the password, it says it is incorrect. Is there anything I am doing wrong here? I'm currently using Ubuntu instead of Windows with Putty, so maybe pasting in the password doesn't work or something?
2 comments
  • Ok.
    So this worked for me.
    logged in with my sudo user (created when doing lamp walkthrough)
    then used command

    su - root
    

    entered new password sent to email
    entered again
    set new password.
    Currently in root and having no issues!

  • Found it. You have to retype the generated password again before entering your new root password.

18 Answers
Have you disabled root/password login? Try logging in through the Remote Console, does that work?

Same issue today. It looks like it's been happening for a few years based on this thread, anyone found a solid answer? :/

I have the same issue. Also login via Remote Console does not work.

  • Are you able to log in using the old password?

    • i am able to login via my ssh key, but nothing else, and it doesn't ask a password.
      when i try to sudo iget stuck since my pass is lost. =\

Same issue. Root password not working via console or any other way.

I've got the same problem and still don't know what to do. Please help.

Yeah, I meet the same problem, the new automatic password is not working. I can only login in through the web embedded terminal. This is really frustrating!

I forget what I did before but all I know now is that whenever I try to reset the root password and login to root@(my_ip) with the newest generated password, I get the message "Permission denied, please try again".

After 3 tries, I get "Permission denied (publickey,password)" -- where do I even begin to deal with publickey?

My root password was working a month ago. Now I tried it and it says incorrect in terminal. I am surprised. Then I reset my password from droplet dashboard. It emailed me new root password. New root password is not working.

Can anyone help to find the solution? Please help.

i think the problem is the root login is disabled via console.
I lost my user password, and now cant use root to reset it, cant login with root since it is hardened.

DO do you have any advice?

Same problem here.

I reset password from droplet dashboard. It emailed me new root password. New root password returns "Access denied"

I can't even log in with web console getting "Server disconnected (code: 1006)" which might be something to do with my network (at a university on public internet access but I can ssh to other places without problem).

Pretty sure i disabled root ssh access in the OS. But now can't get in to change it.

I have another admin user but can't remember its user and pw either.

Any alternative to scraping the enter droplet and starting from scratch?

+1, anyone have thoughts on this?

Ok.
So this worked for me.
logged in with my sudo user (created when doing lamp walkthrough)
then used command

su - root

entered new password sent to email
entered again
set new password.
Currently in root and having no issues!

Same problem here. I opened a support ticket but the response time is horrible. Seems to be an issue that is a known problem and no one on Digital Ocean is responding in this thread. Will definitely be looking into another service after this problem.

Same problem this morning. I have a feeling it's because I disabled password based logins in my provision script... On the plus side I build it with a provision script so it's dad trivial to spin the whole stack back up.

Same problem - root was working a few months ago now it's not. I tried reset via email twice, neither password worked. Also tried rebooting. Can't get in.

Hello,

I had the same issue.

Try to manually enter the password you receive on email as copying a password doesn't work on digital console.

hope it helps.

Thanks

hello, I rebuild my droplet after that reset password, but did not get any email from Digitalocean.
I tried it several times.
also Digitalocean's mail sender is not in blacklist.

Found it. You have to retype the generated password again before entering your new root password.

Have another answer? Share your knowledge.