Roundcube doesn't work in Centos 6 x64

November 24, 2015 837 views
Server Optimization Nginx MySQL CentOS

Hello. I followed this tutoral : everything is fine except roundcube. I can't send or receive e-mails either. Can someone please help me?

Centos 6 x64 Nginx

1 Answer


  • Are you not able to access RoundCube physically (i.e. for instance, when accessing yourdomain.ext/roundcube, are you being denied, seeing an error or something else)?
  • Have you taken a look at your error logs to see if any errors are present that would help to identify an issue?
  • What errors, if any, are you receiving when attempting to login to an e-mail account?
  • Hello and thanks for your reply.
    I am able to access Roundcube ,no problem there.
    No error logs in /var/log/roundcubemail except a sendmail one ,i dont know if this the problem?
    As i told you there is no login problem.. The thing is that i can't send or receive e-mails either.

    • @infin1ty

      The first thing I'd take a look at, given common scenarios, is the part of the setup that asks you to ...set the SMTP server to localhost and set your preferred language. Port 25 is commonly blocked by ISP's and Web Hosting Providers as it's often used to SPAM.

      DigitalOcean just so happens to block that port too, so if you're trying to use Port 25 to send, nothing is going to be sent. You'd need to configure RoundCube to use another port. For example, you could use 2525. You would also need to modify Dovecot to use the same port (since RoundCube is just a script).

      When it comes to receiving, this too could be a setup issue, or it could be a DNS issue. We'd need to take a look at your DNS zone file to make sure all proper DNS entries are in place. Can you post either a screenshot of your DNS or copy and past your config?

      • Thanks again for your answer. Whern i am trying to change the smtp port 25 in /etc/roundcubemail/ i get an SMTP Error (-1) . One other thing that i noticed on ispconfig3 is this message: (on Mail Queue) (connect to[]:10024: Connection refused)

        • @infin1ty

          You'll need to set the port for Postfix as well. Only setting the port in the RoundCube configuration won't change how the actual service handles a connection. RoundCube is only a script :-).

          To do this, you'd want to open /etc/postfix/ using the editor of your choice, for example:

          nano /etc/postfix/

          Search for (if using nano you can press CTRL+W to search):

          smtp inet n – n – – smtpd

          and change it to:

          2525 inet n – n – – smtpd

          The only change we're making is swapping smtp for an actual port number, which is 2525 in this case. You would then restart Postfix:

          sudo service postfix restart

          If ISPConfig provides the ability to do this from within the control panel, it'd be wise to do so there, though if they do not, then making the change from the CLI is how you'd handle this change.

Have another answer? Share your knowledge.