Scale up as you grow — whether you're running one virtual machine or ten thousand.

From GPU-powered inference and Kubernetes to managed databases and storage, get everything you need to build, scale, and deploy intelligent applications.

I have a project with a Dockerfile that roughly has the following:
FROM php:7.2-apache
# supervisor installation &&
# create directory for child images to store configuration in
RUN apt-get -y install supervisor && \
mkdir -p /var/log/supervisor && \
mkdir -p /etc/supervisor/conf.d
# supervisor configurations
ADD /.docker/conf/supervisor/conf.d/apache.conf /etc/supervisor/conf.d/apache.conf
ADD /.docker/conf/supervisor/conf.d/Emails.conf /etc/supervisor/conf.d/Emails.conf
# Docker will start only supervisord
CMD ["/usr/bin/supervisord", "-c", "/etc/supervisor/supervisor.conf"]
apache.conf is supervisor keeping apache alive and Emails.conf is Laravel’
s queue:work command kept alive.
However my app in App Platform fails with:
2021-12-03T10:31:17.440161328Z Unlinking stale socket /var/run/supervisor.sock 2021-12-03T10:31:17.741289162Z Error: Another program is already listening on a port that one of our HTTP servers is configured to use. Shut this program down first before starting supervisord. 2021-12-03T10:31:17.741327485Z For help, use /usr/bin/supervisord -h
The error occurs only in App Platform, Docker builds the container OK.
a6309a057c3f4cb38fb2e7feb67236
KFSys
ef1ed44cc2154be3bcbb2d727878f8
Devs Neonetworks
1e6b823ea20d4cb189a34a922f5588
Telmo Valverde
erik-jan martens
Henry Mui
anthonycarreon
garantieheld
Marin