Question

Running Nginx and Apache for Node Js + Phpmyadmin

Hi, I’ve just succeed to deploy a nodejs app with this great tuto : https://www.digitalocean.com/community/tutorials/how-to-set-up-a-node-js-application-for-production-on-ubuntu-14-04

Now the problem is that I bought my droplet with one click app option to have phpmyadmin pre-install, but to deploy my node js app I had to stop apache run to let nginx run and listening on port 80. Now I can’t access to phpmyadmin because my express routing does not take in charge the route : http://my_ip_adress/phpmyadmin. Please anyone have an idea about how to aces phpmyadmin ? Will my app be able to access to my tables even if apache server off ? Can I just make apache run and listen on port (3000 for example) and Nginx running and listening on port 80 ?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

There are a number of ways you can approach this problem. One is to simply remove Apache all together. You can serve phpMyAdmin with Nginx as well. Check out:

If your setup is working fine as it is, and you just want to make Apache listen on port 3000, you can easily do that too. You’ll need to edit two files and change 80 to 3000

/etc/apache2/ports.conf
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

Listen 3000

<IfModule ssl_module>
        Listen 443
</IfModule>

<IfModule mod_gnutls.c>
        Listen 443
</IfModule>

and

/etc/apache2/sites-enabled/000-default.conf
<VirtualHost *:3000>
# [...]

Finally, restart Apache with sudo service apache2 restart Now your phpMyAdmin interface can be reached at: http://your.ip.addr:3000/phpmyadmin