Script or GUI for SSL Cert Installs?

May 5, 2014 2.2k views
Does anyone know of any bash or curl scripts for, or some kind of GUI for Ubuntu to install SSL certs? I'm using RTCamp's EasyEngine (Nginx) and it runs great, but installing SSL certificates are a pain. I'm looking for something like VestaCP( Thanks!
7 Answers
Hey Sam,

Not sure I've seen anything specifically for that, but if you let us know the issues you're facing installing the SSL certificates I'm sure we can help!

Thank you for the reply.

I'm getting PEM errors when installing the certificates, which I know is either an extra line in the files (CSR, KEY, CERT, etc), or it's in the wrong order. Unfortunately, I've tried everything via the terminal with no luck.

I really like ServerPilot's interface, but I don't think it's worth the money. VestaCP creates SQL errors constantly requiring a new WordPress install. All the other free panels either create errors, or use too much memory.
If you could post the actual errors from /var/log/nginx/error.log and your server block from the nginx config, we might be able to figure out exactly what is going on. Where are you getting your SSL cert from?

This tutorial might be helpful:
by Etel Sverdlov
This tutorial explains how to create a self-signed SSL certificate, how to add it to your server, and how to configure the SSL file to display the certificate to the world. A SSL certificate is a way to encrypt a site's information and create a more secure connection. Certificate Authorities can issue SSL certificates that verify the server's details while a self-signed certificate has no 3rd party corroboration. These steps are for setting up an SSL certificate on Nginx for an Ubuntu server.
I receive this error:

Reloading nginx configuration: nginx: [emerg] PEM_read_bio_X509_AUX(“/var/www/”) failed (SSL:error:0906D066:PEM routines PEM_read_bio:bad end line)
nginx: configuration file /etc/nginx/nginx.conf test failed

I've tried this (, and it doesn't work.
I also forgot to add that I purchased my certificate from RapidSSL.

Thanks Andrew!
Can you pastebin your certificate? Please make sure you do not accidentally post the private key instead.
Why not try ISPConfig. It is the best Open Source control panel I have ever used. Not only does it support nginx you can also setup nginx as a reverse proxy to apache. There is a plugin you have to get though to manage it properly from the ISPConfig panel. However, SSL certificate installation is fairly easy with it as well. Including doing self signed certificates.
Have another answer? Share your knowledge.