Question

Secure phpmyadmin on ISPConfig 3 + nginx (not apache) on Ubuntu 14.04

  • Posted on December 31, 2014
  • saidakhAsked by saidakh

Thank you in advance for any help!

We are running ISPConfig 3 on Ubuntu 14.04 droplet with nginx (not apache). Now we are struggling to find a way to secure phpmyadmin. Found this good tutorial: https://www.digitalocean.com/community/tutorials/how-to-install-and-secure-phpmyadmin-with-nginx-on-an-ubuntu-14-04-server

Yet it works with just nginx setup and not with ISPConfig + nginx.

Can anyone explain us how to secure phpmyadmin on our setup (SPConfig 3 + nginx (not apache) on Ubuntu 14.04)?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Not sure if I am following you completely but here is what I had to do. This is assuming you followed normal ispconfig setup.

In the ispconfig control panel. Click on Server Config Click on your server name. Click on Web Near the bottom click on Vhost apps setting.

Set (All on one line.) It will use your self signed certificate when you setup ispconfig. Apps-vhost port: 8081 ssl; ssl_certificate /usr/local/ispconfig/interface/ssl/ispserver.crt; ssl_certificate_key /usr/local/ispconfig/interface/ssl/ispserver.key

Set Apps-vhost Domain: your.server.name

After the CP updates your should be able to access your phpmyadmin via https://your.server.name:8081/phpmyadmin

This comment has been deleted