Question

Send email using gmail smtp

I’ve followed the tutorial here : https://cloudsupport.digitalocean.com/s/

I’ve tried using port 465 however I had an error so as I use tls I have changed the port to 587, I think 587 is for tls?

I’m getting the following error:

Failed to send AUTH LOGIN command. Error: 530 5.7.0 Must issue a STARTTLS command first. a7sm12831008wra.43 - gsmtp

I’m trying to send email from Expressionengine, I have the following email settings:

$config['email_newline'] = "\r\n";
$config['email_crlf'] = "\r\n";
$config['smtp_crypto'] = 'tls';
Inbound Rules
Custom		TCP		25				All IPv4 All IPv6	More 
HTTP		TCP		80				All IPv4 All IPv6	More 
HTTPS		TCP		443			All IPv4 All IPv6	More 
Custom		TCP		587			All IPv4 All IPv6	More 
				
Outbound Rules
ICMP		ICMP		All IPv4 	All IPv6	More 
All TCP		TCP			All ports	All IPv4 All IPv6	More 
Custom		TCP			587		All IPv4 All IPv6	More 
All UDP		UDP			All ports	All IPv4 All IPv6	More 

Any ideas?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I would assume that you can connect on port 25 as well. It seems that nothing is wrong with the connection itself.

Another thing to add is to enable IMAP from your Gmail account. Login to Gmail and click the gear icon on your top right side of the page, then click Settings --> Forwarding and POP/IMAP --> IMAP access --> Click Enable --> Save Changes

May I ask what was the exact error on port 465? Make sure this port is open for Outbound TCP as well.

I changed the host to ‘ssl://smtp.gmail.com’ port 465 and it works now!

This comment has been deleted