Question

Server domain name replaced with IP address

Posted January 20, 2020 141 views
Apache

I have installed LAMP server and set up website to get resolve the appropriate IP address so when I connect to a server with it’s domain name with an IP address in address bar. It looks like this; /etc/apache2/sites-available/default

NameVirtualHost *:80

<VirtualHost *:80>
        ServerAdmin ...
        ServerName mydomainname.irrelevant.to.the.question

        DocumentRoot /var/www
...

I think that was invented fix that behavior because I also recheck the 3xx redirect path. Path Redirect/RedirectMatch/RewriteRule directives . But in the php application apache won’t misbehave this kind of redirection with their tag Redirect or RewriteRule as I mentioned in the configure file. What else is required?

edited by MattIPv4

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @jacobmillia,

It seems you are using the default Vhost, you need to create a new one for your domain name.

Here is how you can do it

Create a sites-enabled directory

You need to create a sites-enabled directory in your apache’s folder. Depending on the OS it can be either /etc/httpd or /etc/apache2

If you are on CentOS 7 you need to do the following

sudo mkdir /etc/httpd/sites-enabled

If you are on an Ubuntu, you need to

sudo mkdir /etc/apache2/sites-enabled

As soon as you have the folder created open your apache configuration file and add the following to the end of the file :

IncludeOptional sites-enabled/*.conf

Creating your Domain’s Vhost file

Start by opening the new file in your editor with root privileges:

For CentOS

sudo nano /etc/httpd/sites-available/example.com.conf

For Ubuntu

sudo nano /etc/httpd/sites-available/example.com.conf

The file itself should look something like this

<VirtualHost *:80>

    ServerName www.example.com
    ServerAlias example.com
    DocumentRoot /var/www/example.com/public_html
    ErrorLog /var/www/example.com/error.log
    CustomLog /var/www/example.com/requests.log combined
</VirtualHost>

Enable the New Vhost

Now that we have created our virtual host file, we need to enable it so that Apache knows to serve them to visitors.

If you are on CentOS, you need to do

sudo ln -s /etc/httpd/sites-available/example.com.conf /etc/httpd/sites-enabled/example.com.conf

If you are on Ubuntu, you need to

sudo ln -s /etc/apache2/sites-available/example.com.conf /etc/apache2/sites-enabled/example.com.conf

As soon as you are done, restart Apache and you should be good to go

Regards,
KDSys

Submit an Answer