Server extremely slow

November 6, 2018 1.3k views
Nginx CMS Configuration Management LEMP MySQL PHP WordPress

Someone should please come to my aid before this thing makes me do the unthinkable. How can I have a 16GB RAM, 6cores digital ocean droplet. Running on Wordpress with 34 plugins. Linked to Cloudflare and all caching mechanisms in place. Yet my site still takes 50s to load. I have googled and googled and googled, tried all the things I could find online and yet the issue still persists. The issue gets so worse that when I have about 300 realtime users at any instant, I get a 502 error. I have optimized, optimized, optimized and optimized and I’m just so tired about this. Someone should just come to my aid please . What do I do to make my site fast enough and avoid http error when a lot of realtime users are online. I know that a 6GB RAM digitalocean droplet will carry more than 5000 realtime users and still be very fast. Please what am I not doing right? What am I missing? I need all the help I can get please. Someone should give me a configuration settings that will carry this traffic and also what things do I need to constantly do to keep the speed. Please help me.

1 Answer

Hey friend!

There exists quite a bit that impacts the load speed of Wordpress, and physical resources are usually the least of it. To put it simply, one Wordpress site might sustain 5000 simultaneous users with 4GB of RAM, and another Wordpress site may fail to sustain 5 simultaneous users with 64GB of RAM. This is because of customization causing Wordpress to have too much overhead. Those customizations come in the form of plugins and themes.

Try disabling all plugins and switching to a default theme, then see if your page loads quickly. If it does, then you’ve found the path to resolution. Enable your theme, test again. Enable your plugins one by one, testing after each one.

The fastest Wordpress site has 0-1 plugins (none or just caching) and a lightweight theme. Anything above that adds overhead, and any one of those plugins (or the theme) could cause your static caching plugin to fail to function in a way that helps you.

Jarland

Have another answer? Share your knowledge.