Question

Server is slow acessing via domain and via ip quite fast

My server is too slow … I am using 2 core and 2gb ram

domain: ads-max.com

Traffic/day : 500K daily

htop http://image.prntscr.com/image/c895517b20584c219587bbe911011ffa.png

I should go to a more powerful server ?

Mycnf.conf

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
# 
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port		= 3306
socket		= /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket		= /var/run/mysqld/mysqld.sock
nice		= 0

[mysqld]
#
# * Basic Settings
#
user		= mysql
pid-file	= /var/run/mysqld/mysqld.pid
socket		= /var/run/mysqld/mysqld.sock
port		= 3306
basedir		= /usr
datadir		= /var/lib/mysql
tmpdir		= /tmp
lc-messages-dir	= /usr/share/mysql
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address		= 127.0.0.1
#
# * Fine Tuning
#
key_buffer		= 16M
max_allowed_packet	= 16M
thread_stack		= 192K
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover         = BACKUP

#table_cache            = 64

#
# * Query Cache Configuration
#

#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
#general_log_file        = /var/log/mysql/mysql.log
#general_log             = 1
#
# Error log - should be very few entries.
#
log_error = /var/log/mysql/error.log
#
# Here you can see queries with especially long duration
#log_slow_queries	= /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id		= 1
#log_bin			= /var/log/mysql/mysql-bin.log

max_binlog_size         = 100M
#binlog_do_db		= include_database_name
#binlog_ignore_db	= include_database_name
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem

query_cache_size=100M
query_cache_min_res_unit=1K
query_cache_limit=2M

max_connections=90
max_user_connections=30

thread_cache_size=100
table_open_cache=1600
table_definition_cache=200
open-files-limit= 750
wait_timeout=150
interactive_timeout=150
key_buffer_size=300M 
join_buffer_size=1M

max_heap_table_size=200M
tmp_table_size=200M

# Pour le thread_concurrency essayez avec le nombre de CPU x 2
innodb_file_per_table
thread_concurrency=4
expire_logs_days = 3
innodb_buffer_pool_size=35000


[mysqldump]
quick
quote-names
max_allowed_packet	= 16M

[mysql]
#no-auto-rehash	# faster start of mysql but no tab completition

[isamchk]
key_buffer		= 16M

#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @chorao157,

It seems like your MySQL server is trying to do a reverse lookup or a hostname lookup on connection. This is usually only required if your MySQL grants include ‘hostnames’ (for example you setup your MySQL grants with something like this:

GRANT ALL ON mydb.* TO 'myuser'@'blah.com'

Instead of something like this:

GRANT ALL ON mydb.* TO 'myuser'@'10.10.10.5'

If you didn’t, then you could simply disable the DNS lookups (start the server with ‘–skip-name-resolve’). If you did, there’re a few options you have to speed up the process (such as deploying a dnscache with DNSMasq, or perhaps using the hosts file?). Let us know if you need help with either!

i added --skip-name-resolve to my.cnf but i dont see much result…

which conf i put in host files?

ads-max.com IP_DROPLET

?

and how i can make a right config on mysql?