Question

Server Refused My Key :: Windows | Putty -> Digital Ocean

Okay, I am new to Digital Ocean and here’s what I have done so far. I have only 1 droplet in use now.

I created a droplet on Ubuntu 12.x. Initially I wasn’t able to set up SSH (although it was far more seamless to set up the same on AWS). Since I am connecting from a Windows System here is what i did: -

  1. I used PuttyGen to generate the Public Key and Private key. I copy pasted the public key from PuttyGen into the “Add SSH Keys” section in digital ocean and it was accepted.

  2. I then saved my private key locally and configured putty to accept this private key when attempting to connect at port 22.

  3. I tried to log on to digital ocean but it failed saying - “server refused key”.

  4. I then realized that I needed to go to /.ssh and update the authorized_keys file with the same public key that I had copied onto the site’s SSH.

  5. I did this by opening authorized_keys in vi editor and copied the public key signature.

  6. I then tried to connect again from putty using SSH. I still get the “server refused key” and instead have to connect using my password.

Am I missing something here?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I switched to a UNIX Client. Generation and transmission of keys between UNIX systems is seamless. Spent too much time on this Windows-UNIX nonsense and didn’t want to crack my skull anymore on it.