Set permission writable on nginx, php-fpm centos 6.5

May 20, 2015 3.1k views

After i setup lemp I meet problem is can't upload file on my website. I have tried :
chown -R nginx:nginx /var/www/
But don't change anything.

6 Answers

have you tried
sudo chown -R nginx:nginx /var/www/

Ah, right are you trying to write something from the browser or cli.

If you from the browser then the write access would need to be for public.
does the folder have public access.

if not try: chmod -R 757 /var/www/

Are you using php?
could you post the bit of code that you are using to upload.
Whats in the apache error log

  • Yes i am using Wordpress. When i upload file error message " Unable to create directory uploads/2015/05. Is its parent directory writable by the server?"

I am taking a guess at your folder structure here so it may need changing to whatever you have,

chmod -R 777 /var/www/wp-content/

then run

ls -al /var/www/wp-content/

if you see something like this (Mainly the drwxrwxrwx) that will tell you if there is sufficient access

drwxrwxrwx 4 nginx nginx 4096 Apr 30 12:22 uploads

  • Here is result but i still can't upload file
    drwxrwxrwx 8 nginx nginx 4096 May 2 04:22 uploads

Are is there anything in the folder uploads already?
i would check the nginx logs.


There is nothing in the log about file uploads or permissions so its hard to see where your error is coming from.

Although the log does mention that the structure of the files being used is,


and not


Have another answer? Share your knowledge.