Set up non DigitalOcean DNS

September 16, 2015 2.1k views

I am using godaddy DNS. All my records are set up there. How do I point those A records to DigitalOcean.
If I understand correctly, creating DNS records at DigitalOcean will interfere with all my other records, right?

  • Let me add to this:
    I will create A records at godaddy that point to my DigitalOcean IP address.
    How do I configure the DigitalOcean side of things to accept the requests?

  • If you have a droplet on DigitalOcean and a domain purchased elsewhere, just edit domain's DNS settings (in your case at godaddy) so that A records point at your droplet's IP address.

2 Answers
by Etel Sverdlov
This article walks you through setting up the DNS for your site. The tutorial includes steps to set up an A records, point your nameservers, and provides some information about MX records.
  • Thank you, but NOPE.

    If I do that, I believe my e-mail and all my other A records will stop working. I do not want DigitalOcean to do my DNS. I already have the DNS set up.

    I only want DigitalOcean to host my website.

    My droplet's host name is the same as my domain name.
    I created a CNAME with "www" pointing to my <>.

    My current DNS (godaddy):
    For the domain name in question, I pointed "@" and "www" to my IP address here.

    So far it's working. If anything is missing, I'll figure it out as I set up my website.

    • This is correct, and your current setup should work fine.
      Just let your DO droplet handle the requests of the domain you would like to use, with a proper VHOST configuration.

In Apache you can copy the default file, and edit the new VHOST to handle your requests. Or you can simply create a new VHOST and just add whats needed. If you don't want to use the default config, go to #2;

sudo cp /etc/apache2/sites-available/000-default.conf /etc/apache2/sites-available/
2Now edit the new vhost (or create a new one):
sudo nano /etc/apache2/sites-available/

And you should use a simple, but efficient config like this:

<VirtualHost *:80>
    DocumentRoot /var/www/
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

I am not sure were the default directory of Wordpress is, since I never use the one-click application wizard. Just check where it is, and make sure you use the proper one at DocumentRoot
Now enable your VHOST and everything should work fine:

sudo a2ensite

Just run a droplet with the wordpress app installed to test, the default directory is /var/www/html. So inside your VHOST, use:
DocumentRoot /var/www/html

Have another answer? Share your knowledge.