Question

Set up vsftpd but now I'm getting 550 Permission denied error

  • Posted July 19, 2013

Can anyone help me so I can use ftp to log into my virtual private server using filezilla.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I found a solution on the net. <br> <br>Here it is: <br> <br>1. login as root (or sudo…) and do the following: <br> <br>2. apt-get install python-software-properties <br> <br>3. sudo add-apt-repository ppa:thefrontiergroup/vsftpd <br> <br>4. sudo apt-get update <br> <br>5. sudo apt-get install vsftpd <br> <br>6. vi /etc/vsftpd.conf and add the following <br>allow_writeable_chroot=YES <br> <br>7. sudo service vsftpd restart

I found a solution on the net. <br> <br>Here it is: <br> <br>1. login as root (or sudo…) and do the following: <br> <br>2. apt-get install python-software-properties <br> <br>3. sudo add-apt-repository ppa:thefrontiergroup/vsftpd <br> <br>4. sudo apt-get update <br> <br>5. sudo apt-get install vsftpd <br> <br>6. vi /etc/vsftpd.conf and add the following <br>allow_writeable_chroot=YES <br> <br>7. sudo service vsftpd restart

I found a solution on the net. <br> <br>Here it is: <br> <br>1. login as root (or sudo…) and do the following: <br> <br>2. apt-get install python-software-properties <br> <br>3. sudo add-apt-repository ppa:thefrontiergroup/vsftpd <br> <br>4. sudo apt-get update <br> <br>5. sudo apt-get install vsftpd <br> <br>6. vi /etc/vsftpd.conf and add the following <br>allow_writeable_chroot=YES <br> <br>7. sudo service vsftpd restart

I found a solution on the net. <br> <br>Here it is: <br> <br>1. login as root (or sudo…) and do the following: <br> <br>2. apt-get install python-software-properties <br> <br>3. sudo add-apt-repository ppa:thefrontiergroup/vsftpd <br> <br>4. sudo apt-get update <br> <br>5. sudo apt-get install vsftpd <br> <br>6. vi /etc/vsftpd.conf and add the following <br>allow_writeable_chroot=YES <br> <br>7. sudo service vsftpd restart

How did you set it up?

IT’S WORK!!!

just turn off your ‘firewall’

Just follow this steps and you are good to go :) Default linux ftp client doesn’t allow write [ mput will fail] Be in superuser [su/sudo] vi /etc/vsftpd.conf uncomment follwing line write_enable=YES killall vsftpd [ respawn again] now you shouldn’t get access denied

Yes I can log in. I’m still getting the same error even after reinstalling vsftpd. There’s definately a permissions problem somewhere along the line but I don’t know how to solve it.

When is it that you get the 550 permission denied error? Are you able to log in via FileZilla?