526dae9f3f8728d99b513486b0f6c51af11e1b93
By:
LukasMalk

Setting the FQDN in CentOS 7?

April 14, 2016 3.3k views
Getting Started Linux Basics Firewall System Tools CentOS

Hi,
I struggle with setting the FQDN in CentOS 7. My hostname is MyWebSpace and my domain for example is mywebspace.io. Below is my current configuration:

# Your system has configured 'manage_etc_hosts' as True.
# As a result, if you wish for changes to this file to persist
# then you will need to either
# a.) make changes to the master file in /etc/cloud/templates/hosts.redhat.tmpl
# b.) change or remove the value of 'manage_etc_hosts' in
#     /etc/cloud/cloud.cfg or cloud-config from user-data
# The following lines are desirable for IPv4 capable hosts
127.0.0.1 MyWebSpace MyWebSpace
127.0.0.1 localhost.localdomain localhost
127.0.0.1 localhost4.localdomain4 localhost4

# The following lines are desirable for IPv6 capable hosts
::1 MyWebSpace MyWebSpace
::1 localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6

Can someone show me how to set my FQDN correctly? For example I struggle to understand if I can just set mywebspace.io as FQDN or if I need to add a prefix like whatever.mywebspace.io.

Any hints?

3 Answers

Hi Lukas,

Your FQDN needs to be the absolute hostname: yourserverhostname.yourdomain.io.
You can find out your hostname by running hostname from your terminal, and then using that output to create your FQDN.

Hope that clears things up, but let me know if you need any more clarification.

PROCEDURE OF SETTING FQDN ON CENTOS 7 -

Step 1 – Login to your server / VPS as root or as a user with root privilege.

Step 2 – Check current hostname:

1 hostname

Step 3 – You may also want to find out status of your server and its hostname using hostnamectl command:

1 hostnamectl status

Step 4 – Now here’s the magic command to change default CentOS 7 hostname without having to reboot your server:

1 hostnamectl set-hostname fqdn.host.name

Change fqdn.host.name to your own FQDN hostname. Example:

1 hostnamectl set-hostname servedby.servermom.org

So if you issue the hostnamectl status command again, you’ll see it changed. But however you’ll only see it has really changed if you close current session and reopen new SSH session (get out and login back)

  • But this "breaks" the command "hostname"! You're supposed to get just the hostname (without the domain part) when omitting '-f'.

    • I googled a bit more and apparently centos/rhel think/recommend that your hostname is your fqdn...

Thanks for the Clarification :)

Have another answer? Share your knowledge.