Question

Setting up domains

Now i have to admit i’m not the best guy at domains and shit like that but i’m REALLY confused. i have onlydomains domain (artsenpai.com) and i just pointed them to digitalocean nameservers… and they don’t work at all (apache not loading just plain redirecting to onlydomains). i have talked to onlydomains support and they tell me THIS (admin i talked to):

  1. you’ve delegated fine but you are submitting an inordinate amount of delegatoins; you need to stop resubmitting the delegation, it’s alreadyd one; 2) your main issue is the digitalocean name servers aren’t responding for your domain, that’s something you need to address with digitalocean

Querying a.root-servers.net (198.41.0.4)… delegated Querying e.gtld-servers.net (192.12.94.30)… delegated Querying ns2.digitalocean.com (173.245.59.41)… refused Querying ns1.digitalocean.com (173.245.58.51)… refused Unable to find: artsenpai.com

and then they tell me i need to address this to… digitalocean i guess? i’m really confused. i need help

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This guide may be helpful in setting up your domain with the DigitalOcean DNS services.

I think I was able to track down the problem. Querying our servers for www.artsenpai.com gives me a result

> www.artsenpai.com
Server:		ns1.digitalocean.com
Address:	173.245.58.51#53

Name:	www.artsenpai.com
Address: 104.131.159.64

But querying for artsenpai.com does not.

> artsenpai.com
Server:		ns1.digitalocean.com
Address:	173.245.58.51#53

** server can't find artsenpai.com: REFUSED

This would lead me to believe that you created a zone in the DigitalOcean DNS services for the subdomain www.artsenpai.com instead of the domain itself (artsenpai.com). Deleting the current zone and re-creating it for your domain itself should resolve the problem.

This comment has been deleted