Question

Setting up mail server with postfix and dovecot trouble.

Posted March 29, 2014 2k views
Hello, I posted the following in a ticket to DO support and they directed me here to ask, as they do not have access to customers' droplets. Perhaps you guys can help out! I've been working on a guide from arstechnica for a week or two on setting up a mail server on a VPS. I've done all the configuring on the server and I think I have all of the DNS stuff correct; however, when I send mail to the server or try to connect using a mail client (like Thunderbird) the server never receives the e-mail and the client is unable to connect. Additionally, my e-mails aren't being kicked back to my gmail account. I've looked through the mail and sys logs and there are no errors reported and no indication of the receipt of emails. I've tried to telnet to the proper ports (secure smtp, secure imap, etc.) and receive unable to connect messages. Lastly, I've added an MX and a couple TXT records to my DNS, but they haven't appeared yet with a Dig command or on who.is/robtex. I updated them early this morning. Is there something I'm missing? Are the ports for the secure mail blocked, or is my DNS not proper? I feel that if I messed up my config I'd have seen it in the logs, so I'm guessing the problem is external. The domain is tinkerduck.com Thanks in advance, Carl Additional - I tried to do an MX lookup using this: http://www.adminkit.net/mxlookup.aspx and there was no MX record found, even though I added one to my DNS at about 4am (EST) today. Also, I added standard mail ports (25, 143, 587, 993) to iptables as allowed.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

1 answer
Your MX record appears to be in place. I can also telnet to port 25 on your mailserver.

Are you still experiencing this issue?
Submit an Answer