Question

setting up ssh tunnel to phpmyadmin

I followed the instructions on installing and securing phpmyadmin. https://www.digitalocean.com/community/tutorials/how-to-install-and-secure-phpmyadmin-with-nginx-on-an-ubuntu-18-04-server

Everything worked, except when I got to the last section on ssh tunneling, I ran into issues. I’m not sure what’s causing it, but I’m getting: localhost refused to connect. I am only using secure access, so my script is this:

ssh userid@domain -L 8443:localhost:443 -N

It freezes like it is supposed to, but when I try to access, my server refuses to connect. I turned off the firewall and it is still an issue.

Thanks, …Chad


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @chadleyb

Are you able to visit the page of the phpMyAdmin installation without the ssh tunnel? You can make sure that phpMyAdmin is accessible without the tunnel and also without the additional authentication in order to make sure that the issue is with the last step in setting the ssh tunnel and not with the actual configuration of phpMyAdmin

Let me know how it goes.

Regards, Alex