Question

Setting up Sublime Text's FTPSync

Has anyone here set up the FTPSync plugin for Sublime Text to work with their DigitalOcean server?

I’ve tried and I can’t seem to get it working. Here’s what I did:

  • Right clicked my folder in Sublime, FTPSync > Set up FTPSync in this folder
  • Edited my settings file to the following:

<pre> { “default”: { “host”: “example.com”, “username”: “my_username”, “password”: “my_password”, “path”: “/var/www/my_site/”,

	"upload_on_save": true
}

} </pre>

And it still doesn’t work. Anyone got any suggestions?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi,

after quiet a battle and a lot of help from crazydc and NoxArt at GitHub I’ve successfully set up FTPSync to work.

You need to match the FTP user and the owner of the files and folders you’re attempting to sync. So if your FTP user is root, it should also be the owner of the files and folder you’ll be working with.

I just use a default configuration:

{
    "primary": {
        "host": "146.1.14.7",
        "username": "root",
        "password": "password",
        "path": "/home/something",

        "upload_on_save": true
    }
}

meant to say hope it helps

This was the setup I used for my config...maybe you were having dns issues. I know I had a trailing slash on my address the was hanging me up. 

<br> <br> Be that as it may, I can verify that I have Sublime Text 3 using the sftp plugin to map to my Digital Ocean server…hope <br> <br>{ <br> // The tab key will cycle through the settings when first created <br> // Visit http://wbond.net/sublime_packages/sftp/settings for help <br>
<br> // sftp, ftp or ftps <br> “type”: “sftp”, <br> <br> “save_before_upload”: true, <br> “upload_on_save”: true, <br> “sync_down_on_open”: false, <br> “sync_skip_deletes”: false, <br> “sync_same_age”: true, <br> “confirm_downloads”: false, <br> “confirm_sync”: true,
<br> “confirm_overwrite_newer”: false, <br>
<br> “host”: “107.170.xxx.xx”, <br> “user”: “root”, <br> “password”: “my password”, <br> //“port”: “22”, <br>
<br> “remote_path”: “/var/www/”, <br> “ignore_regexes”: [ <br> “\.sublime-(project|workspace)”, “sftp-config(-alt\d?)?\.json”, <br> “sftp-settings\.json”, “/venv/”, “\.svn/”, “\.hg/”, “\.git/”, <br> “\.bzr”, “_darcs”, “CVS”, “\.DS_Store”, “Thumbs\.db”, “desktop\.ini” <br> ], <br> //“file_permissions”: “664”, <br> //“dir_permissions”: “775”, <br>
<br> //“extra_list_connections”: 0, <br> <br> “connect_timeout”: 30, <br> //“keepalive”: 120, <br> //“ftp_passive_mode”: true, <br> //“ftp_obey_passive_host”: false, <br> //“ssh_key_file”: “~/.ssh/id_rsa”, <br> //“sftp_flags”: [“-F”, “/path/to/ssh_config”], <br>
<br> //“preserve_modification_times”: false, <br> //“remote_time_offset_in_hours”: 0, <br> //“remote_encoding”: “utf-8”, <br> //“remote_locale”: “C”, <br> //“allow_config_upload”: false, <br>}