Question

Setting up user with pg_monitor role

Posted February 24, 2020 3k views
PostgreSQLDigitalOcean Managed PostgreSQL Database

In order to do datadog monitoring I need an user with the role pg_monitor, however I cannot grant this role since I need the admin option, which can only be given when initially granting the role to an user (which you need superusr for). Any workaround / tricks I didn’t think of?

2 comments
  • +1 On this. I’d like to do something as simple as issue a COPY command to write a csv into the database but can’t because the doadmin user does not have SUPERUSER privileges. Please help or else I’ll have to ditch Digital Ocean’s hosted Postgres warehouse. I wish you would make these sort of limitations clear upfront. It’s really disheartening to see from an otherwise transparent organization.

  • Is there any update here? If not, how are people monitoring their Postgres databases? Just switching away from Digital Ocean?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
5 answers

Hi @hest -

Thank you for bringing this to our attention. There is not currently a workaround for this scenario. We are aware of the issue and are actively exploring options to provide the outcome you outline.

We have the same problem, Please resolve this, it is already half a year

Same problem here, we need to set up datadog integration asap

You can use an existing doadmin account. I’ve just set everything up =) Or you can try to create an account via console =)

Does anyone have a solution ? is there in DO backlog ?

I really need this for monitoring via Datadog..