Question

Setup apache error

  • Posted April 18, 2014

I have just followed the instructions in this link:

https://www.digitalocean.com/community/articles/how-to-set-up-apache-virtual-hosts-on-centos-6

But my apache won’t start, any idea why? Thank you.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello there,

Everyone can check our series of tutorials under the How To Set Up Apache Virtual Hosts

https://www.digitalocean.com/community/tutorial_collections/how-to-set-up-apache-virtual-hosts

Hope that this helps!

Hello there,

I will recommend you to check the Apache config file (also PHP-FPM if you use it) for any syntax errors or other misconfiguration that can lead to those errors.

However, those messages are from search-engine bots which are crawling the website.

I also want to include great tutorials on Common Apache Errors and How To Troubleshoot Common Apache Errors that you can find really useful if you run into an Apache error and you need some help.

https://www.digitalocean.com/community/tutorial_series/common-apache-errors

https://www.digitalocean.com/community/tutorials/how-to-troubleshoot-common-apache-errors

Also, this question was previously posted and answered by Bobby which you can check here:

https://www.digitalocean.com/community/questions/how-to-troubleshoot-common-apache-issues-on-linux-server

Feel free to then share the output of the commands listed in that tutorial.

Hope that this helps!

It is correct, i am not really sure why the text is removed. The apache has started successfully. <br> <br>< VirtualHost *:80 > <br> ServerAdmin webmaster@cendivo.com <br> DocumentRoot /var/www/cendivo.com <br> ServerName www.cendivo.com <br> ServerAlias cendivo.com <br> ErrorLog /var/www/cendivo.com/error.log <br> CustomLog /var/www/cendivo.com/requests.log common <br>< /VirtualHost > <br>

It looks like digital ocean is escaping what it thinks is html (please excuse the added spaces) <br> <br>Surround your directives with <br> <br>< VirtualHost *:80 > <br> <br>< / VirtualHost *:80 >

Make sure to surround your virtual host directives with <br> <br><VirtualHost *:80> <br>… <br></VirtualHost *:80> <br> <br> <br>“The error is just with the url. Not big of a deal. Just missed it. Thank you for your help.” <br> <br>Do you have it working?

Here is the vhosts section of the file: <br> <br>NameVirtualHost *:80 <br># <br># NOTE: NameVirtualHost cannot be used without a port specifier <br># (e.g. :80) if mod_ssl is being used, due to the nature of the <br># SSL protocol. <br># <br> <br># <br># VirtualHost example: <br># Almost any Apache directive may go into a VirtualHost container. <br># The first VirtualHost section is used for requests without a known <br># server name. <br># <br><VirtualHost *:80> <br> ServerAdmin webmaster@cendivo.com <br> DocumentRoot /var/www/cendivo.com <br> ServerName www.cendivo.com <br> ServerAlias cendivo.com <br> ErrorLog /var/www/cendivo.com/error.log <br> CustomLog /var/www/cendivo.com/requests.log common <br></VirtualHost> <br> <br> <br>The error is just with the url. Not big of a deal. Just missed it. Thank you for your help.

What was the error thrown when apache didn’t start? That may be a hint of something in your httpd.conf not properly set. How did you fix it to get apache to start?

Will you paste the contents of the vhosts section of your apache httpd.conf file. <br> <br>

@colin I have placed in /var/www/domain.com/public_html/ just like as instructed in this link: <br> <br>https://www.digitalocean.com/community/articles/how-to-set-up-apache-virtual-hosts-on-centos-6 <br> <br>

Where do you have your index.html file placed?