Question

Setup postfix and dovecot for domain

  • Posted September 12, 2014

I cannot get my mail working with virtualmin, dovecot and postfix

I have tried every setting. If I try to authenticate via my mailclient, I get an error instantly

If I try webmail (roundcube) I get: ‘SMTP authentication failed’.

I already checked:

  • If dovecot was running under port 143
  • if the mailserver I use (mail.mydomain.com) points to the correct IP
  • if the user is listed in virtualmin under my domain
  • I did re-check configurattion and everything is OK
  • Sending mail from usermin is also not working, gives 'Failed to send mail : SMTP command . failed : 451 4.3.0 Error: queue file write error ’
  • Sending mail to the mailadres is not working too (no error in mailclient, just not sent or received)
  • I have set-up this DNS records: mail.mydomain.com. , pointing to MY vps-s IP (A record) and an Mx record vor mail.mydomain.com.
  • In webmin I checked if both dovecot and postfix are up&running
  • I tried numerous other settings but nothing seems to work

What now? Where do I start debugging?

PS: I don`t now if this matters, but the VPS mainserver (the domain I talk about here is a subserver), the mainserver is a subdomain like: srv5.myserversdomain.com. This hostname (srv5) points to the VPS. On the VPS I run virtualmin and withing virtualmin I have srv5.myserverdomain.com as mainserver and mydomain.com as subserver. The website is working fine for mydomain.com, just the mail not.

PS, I tailed the log too this gives 2 errors all the time: > queue file write error > hash: /etc/postfix/bcc is unavailable. open database /etc/postfix/bcc.db: no such file or dir > sender_bcc_maps_lookup porblem

Thanks a lot!

Subscribe
Share

Sure. Here you can find like 4 hours of recent logging. I used mail.log, assuming that is where postfix logs to? http://we.tl/EswBOaPIAs

Can you post the postfix log file please?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This comment has been deleted