Question

SFTP Connection Error Received unexpected end-of-file from SFTP server

Hi, I was be able to connect my server via filezilla till today. I installed lamp and configured dns server after that I’m unable to access to my server via sftp. It say’s Received unexpected end-of-file from SFTP server

Subscribe
Share

I seem to be having the same issue. SFTP through Filezilla was working perfectly a couple days ago. Then I updated to a newer version and it is no longer able to connect. Been scouring the internet all evening looking for a solution, any suggestions would be greatly appreciated.

Same issue with filezilla and cyberduck.

yeah I’ve done that update too. I think for now you should use WinSCP as ftp client


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

        Hi, my answer is this: The DigitalOcean for security reasons if you made a droplet just right now or reseted root password and you want to login to the VPS via FTP Connection you should before connecting to your SSH Console and log in and then change your password(In your SSH you will see Enter Unix Password and then Enter New Password so you will see...) .
        Then with the new password you can log in via FTP...
         Hope this helps, my problem has been solved since I did this.
        Hi, my answer is this: The DigitalOcean for security reasons if you made a droplet just right now or reseted root password and you want to login to the VPS via FTP Connection you should before connecting to your SSH Console and log in and then change your password(In your SSH you will see Enter Unix Password and then Enter New Password so you will see...) .
        Then with the new password you can log in via FTP...
         Hope this helps, my problem has been solved since I did this.

I had the same issue. It got resolved after I logged into console and changed the password from the generated one @ reset email.

See if it helps.

I had the same issue. It got resolved after I logged into console and changed the password from the generated one @ reset email.

See if it helps.

Fattur, I was able to solve my issue by logging into SSH and editing the sshd_config file:

sudo nano /etc/ssh/sshd_config

Then scroll down until you see this line:

# Subsystem sftp /usr/lib/openssh/sftp-server

Leave that line commented out, but underneath it write this:

Subsystem sftp internal-sftp

Then power cycle your server and the problem should be fixed. I’m now using the latest version of Filezilla without any issues.

Fattur, I was able to solve my issue by logging into SSH and editing the sshd_config file:

sudo nano /etc/ssh/sshd_config

Then scroll down until you see this line:

# Subsystem sftp /usr/lib/openssh/sftp-server

Leave that line commented out, but underneath it write this:

Subsystem sftp internal-sftp

Then power cycle your server and the problem should be fixed. I’m now using the latest version of Filezilla without any issues.

Fattur, I was able to solve my issue by logging into SSH and editing the sshd_config file:

sudo nano /etc/ssh/sshd_config

Then scroll down until you see this line:

# Subsystem sftp /usr/lib/openssh/sftp-server

Leave that line commented out, but underneath it write this:

Subsystem sftp internal-sftp

Then power cycle your server and the problem should be fixed. I’m now using the latest version of Filezilla without any issues.

Fattur, I was able to solve my issue by logging into SSH and editing the sshd_config file:

sudo nano /etc/ssh/sshd_config

Then scroll down until you see this line:

# Subsystem sftp /usr/lib/openssh/sftp-server

Leave that line commented out, but underneath it write this:

Subsystem sftp internal-sftp

Then power cycle your server and the problem should be fixed. I’m now using the latest version of Filezilla without any issues.

Fattur, I was able to solve my issue by logging into SSH and editing the sshd_config file:

sudo nano /etc/ssh/sshd_config

Then scroll down until you see this line:

# Subsystem sftp /usr/lib/openssh/sftp-server

Leave that line commented out, but underneath it write this:

Subsystem sftp internal-sftp

Then power cycle your server and the problem should be fixed. I’m now using the latest version of Filezilla without any issues.

Check our filezilla settings if you got anything weird configurated in there like proxy, and check if you are using passive mode. You could also try to use WinSCP client to check if that works