Question

SFTP deployment through Hexo is failing because the $SSH_AUTH_SOCK env variable isn't set

Ok, I’m trying to deploy using hexo deploy with their SFTP connector and I’m getting a ‘Timed out while waiting for handshake’ and I think it’s because it’s looking for an environment variable $SSH_AUTH_SOCK on the server and it isn’t set. The $SSH_AUTH_SOCK is the hexo default, I could change it but basically I need an env variable that points to the agent path.

Hexo doc for this feature is here, https://hexo.io/docs/deployment.html#SFTP specifically the agent parameter.

Any ideas?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi~ I just used the default ssh private key without ssh-agent and I came across the same error, but I finally found that it was because my network had broken down…

Are you running an ssh-agent?