Question

SFTP error using Cyberduck: EOF while reading packet

  • Posted October 18, 2014

I am trying to host my website using a droplet and I am using Cyberduck on MacOSX. While setting up the SFTP I get receive a “connection failed” alert and it reads, “EOF while reading packet”.

When I tried on FileZilla it responds with: Error: Connection closed by server with exitcode 1 Error: Could not connect to server

I searched around for help and I could not find anything helpful (I’m a novice).

Subscribe
Share

This comment has been deleted

I have the same problem. Create a new doplet, even add a ssh key. I can not also access on my doplet via IP adress, also wordpress dont setup auto on creating. Something is wrong. First time i see this problem.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

figured it out. after i ssh’d to the account it prompted me to change the password which later worked in FTP.

For me the problem was an incorrect path in my /etc/ssh/sshd_config.

I had:

Subsystem sftp /usr/lib/ssh/sftp-server

which didn’t exist. I needed:

Subsystem sftp /usr/lib/openssh/sftp-server

same here. tried resetting my password

Same problem here too… any advise?

I have the same error :(