Question

sftp filezilla cant connect login stopped working after upgrading ubuntu 20

Posted October 26, 2021 196 views
Ubuntu 20.04

Hi I upgraded to ubuntu 20 and now I can’t connect using filezilla sftp.

I’ve tried a couple things but no luck.

I can connect using SSH like this -

ssh user@12.345.67.891
The authenticity of host ‘12.345.67.891 (12.345.67.891)’ can’t be established.
ECDSA key fingerprint is SHA256:UJ0gg08e0RuTvhrsktQYy70RzO8mM6i9wlYm8oVztHU.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added '12.345.67.891’ (ECDSA) to the list of known hosts.
sftp user@12.345.67.891
user@12.345.67.891 password:
Connected to 12.345.67.891.
sftp> exit

Why doesn’t it let filezilla connect?

I’ve compared the old sshdconfig file with the new sshdconfig post ubuntu upgrade and they are exactly the same.

Here’s a snippet from /var/log/auth.log.. Does this look right?

Oct 26 04:45:23 spock sshd[33510]: Received disconnect from 1.23.45.678 port 49278:11: Unsupported cipher [preauth]
Oct 26 04:45:23 spock sshd[33510]: Disconnected from 1.23.45.678 port 49278 [preauth]
Oct 26 04:45:44 spock sshd[35532]: rexec line 16: Deprecated option UsePrivilegeSeparation
Oct 26 04:45:44 spock sshd[35532]: rexec line 19: Deprecated option KeyRegenerationInterval
Oct 26 04:45:44 spock sshd[35532]: rexec line 20: Deprecated option ServerKeyBits
Oct 26 04:45:44 spock sshd[35532]: rexec line 31: Deprecated option RSAAuthentication
Oct 26 04:45:44 spock sshd[35532]: rexec line 38: Deprecated option RhostsRSAAuthenticatio

Please can someone point me in the right direction?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi @twc8ac35a8636,

The first thing I can say which might be a bit of a stretch is to make sure you are using port 22 in FileZilla.

Additionally, try and allow your IP in your firewall for all ports just to see if that would help out.

Another suggestion is to use a Key with Filezilla rather than a Password, I think that was possible as well. Just to see if it would work.

  • Hi @KFSys,

    Port 22 is selected in the sftp program.

    I’ve added my IP to the firewall using this cmd but still doesn’t connect -

    sudo ufw allow from 123.456.78.9
    
    

    I haven’t had to add my IP to the firewall before. I have Fail2Ban and my IP is also whitelisted there.

    The key method isn’t working either.

    I’m still getting this message in /var/log/auth.log when trying to connect using sftp program -

    Oct 26 09:08:26 spock sshd[395566]: rexec line 16: Deprecated option UsePrivilegeSeparation
    Oct 26 09:08:26 spock sshd[395566]: rexec line 19: Deprecated option KeyRegenerationInterval
    Oct 26 09:08:26 spock sshd[395566]: rexec line 20: Deprecated option ServerKeyBits
    Oct 26 09:08:26 spock sshd[395566]: rexec line 31: Deprecated option RSAAuthentication
    Oct 26 09:08:26 spock sshd[395566]: rexec line 38: Deprecated option RhostsRSAAuthentication
    Oct 26 09:08:26 spock sshd[395566]: Received disconnect from 123.345.678.9 port 55202:11: Unsupported cipher [preauth]
    Oct 26 09:08:26 spock sshd[395566]: Disconnected from 123.345.678.9 port 55202 [preauth]
    

    Any more ideas as to what is stopping the sftp program from connecting?

    Thanks for your help