Question

Shutdown fails to shutdown droplet

Posted December 2, 2013 9.2k views
I can't shutdown my droplet it stays in the active state even after sudo -r shutdown now it still doesn't shutdown

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
5 answers
Try pinging your droplet, is it still up? If not, please wait for a few minutes until its status is updated on the hypervisor.
Have you tried:
sudo shutdown -h now
The -r option to shutdown performs a reboot, thus your droplet shuts down but immediately starts again.

The command you want is "sudo shutdown -P now" or "sudo shutdown -h now".



sudo shutdown -h now is that i typed and it said it was going to shutdown. I think i made a mis type.
There's a difference between -h (halt) and -P (power off). You really want to power off your droplet rather halting. For a KVM VPS (droplet) it should have the same behavior but it's possible that something is not configured properly. I recommend you to always use "shutdown -P now" or even simpler: "poweroff".

As per the shutdown manual:

-h Requests that the system be either halted or powered off after
it has been brought down, with the choice as to which left up to
the system.

-P Requests that the system be powered off after it has been
brought down.

Shortcut commands:
shutdown -h now = halt
shutdown -r now = reboot
shutdown -P now = poweroff
Submit an Answer