Question

Site can't be reached, Ping fine, DNS check fine, Certbot renewed

Posted May 5, 2020 238 views
LEMPLet's EncryptUbuntu 18.04

Hi guys,

I had this droplet for a long time and never had this issue. Test domain is www.jetpackstudio.ca.

DNSCheck turns out green. You can ping the domain or droplet IP with response but I just can’t get on the website. Error message is “This site can’t be reached, www.jetpackstudio.ca took too long to respond.

I’m afraid to run Certbot again because I know it’s limited to 5 renew per 7 days.

UFW Port22, 80, 443/tcp allowed.

LEMP Stack, 18.04.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

SOLVED: Restarted UFW and it worked. This seems like a common step after a droplet reboot. If anyone knows why, please let me know!

Hello, @emailandychen

Could you please let us know if the service was running after the droplet’s reboot or was inactive?

The general troubleshooting after droplet reboot will be to make sure all services have started successfully. If the site was not loading I will also check if the web server (Apache, Nginx) is also running as this will usually be the cause of the issue.

Thanks for explaining what was the culprit of the problem for you as this might help some other users too. Feel free to share how the troubleshooting process went and what commands did you executed to get this sorted.

Regards,
Alex

  • Alex,

    The everything on the droplet was up and running. The only thing I had to do was to disable and re-enable ufw. It is a repeatable issue on every reboot.

    Have you guys seen this issue on other droplets?

Submit an Answer