Site does not load after upgrading to 18.04

I upgraded from 16.04 to 18.04 and now when I visit the site, it says “ERR_CONNECTION_REFUSED”.

Running WordPress

I thought it was maybe certbot, and tried renewing certs which gives the error

The apache plugin is not working; there may be problems with your existing configuration.
The error was: NoInstallationError('Cannot find Apache executable apache2ctl')

I tried visiting via IP address and it also says “ERR_CONNECTION_REFUSED”

Your help would be appreciated.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello there,

I want to include great tutorials on Common Apache Errors and How To Troubleshoot Common Apache Errors that you can find really useful if you run into an Apache error and you need some help.

Also, this question was previously posted and answered by Bobby which you can check here:

Feel free to then share the output of the commands listed in that tutorial.

Hope that this helps!

Hi @MPA,

I think Cerbot crashed before it obtained the certificate for you.

You can fix that problem by also adding /usr/local/bin/certbot-auto --apache --apache-server-root /etc/httpd --apache-ctl apachectl. That will allow you to get a new certificate.

Hope helps you, Sergio Turpín