Site gone after resetting root password

September 25, 2018 374 views
Apache DigitalOcean

Hi,

I reset my root password today and all of a sudeen my whole site is gonew. The home page shows “Apache2 Ubuntu Default Page” and a long mesage.

I would appricte any help. Thank you very much in advance.

2 Answers

Hey friend!

This may seem like an off the wall guess, but nearly every time I see this problem it’s because someone had installed both Nginx and Apache, and on reboot Apache started first so Nginx then could not (couldn’t bind to port). Just for kicks, try this:

systemctl stop apache2
systemctl start nginx

If that works, run this next:

systemctl disable apache2

Jarland

Hi Jarland,

Thank you very much. You are a lifesaver. It worked.

I used these two commands:

systemctl stop apache2

systemctl start nginx

It gave this message “nginx failed to start…” but it fixed the problem so the site is back up.

For anyone (who like me doesn’t know much about managing servers or where to even enter the commands Jarland gave) in the future facing the same issue, here’s what you do:

  1. Login to your DigitalOcean account.

  2. Click on the droplet you are having the problem with.

  3. Click “access” from the left menu.

  4. HWne the black screen opens up, enter - copy then past (ctrl + v) - these two commands:

systemctl stop apache2

systemctl start nginx

Hit “enter” after pasting each command.

This should (hopefully) solve the problem. It did for me.

Jarland, once again, thank you very much for taking the time out of your busy day to help a stranger out. I really appreciate it. You saved me hours of stress. Thank you.

Have another answer? Share your knowledge.