When I followed the tutorial and went to create my .conf file for my laravel project. Nginx did not have a sites-available or sites-enabled directory?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @alexgq3,

This is because you have installed Nginx from the Nginx repository. Instead of the sites-available/sites-enabled directory, you get conf.d directory. Navigate the conf.d directory and disable the default configuration.

sudo mv default.conf default.conf.disbaled 
sudo nginx -s reload

Now you can create a new configuration file for your web. Don’t worry all the procedure is similar.

If anything else, please let me know.

Submit an Answer