Question

Slow connection when using private hostname

Current setup:

  • MySQL Managed Database.
  • Droplet with our web server (nginx + php-fpm).

Both servers are hosted in the same network.

We recently ran into a problem when using a Managed MySQL database in a PHP application that is under higher load (200-300 requests / minute). Initially the requests were quiet fast but when the load increased the application became slower. We were able to trace this back to the part where we connect to our database using the private hostname.

Our problem appears to be fixed once we switched to using the private IP instead of the hostname. We suspected that there is some DNS resolution going on that caused the delay.

I’m wondering if this is a known issue and if there is a better way to fix it? For our Redis server we had a similar issue that was solved once we added the private IP and hostname to /etc/hosts.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

i have the same problem with digitalocean manage dababase. and make me lot of problem and spend my time.

jus add private db host name in /etc/hosts we get 10x speed.

ab -n 1000 -n 100 https://xxxx.xxxx.com/luke/ without setting db hosts in local take:5.762 seconds

with setting db hosts in local Take:0.6 seconds

Hi @bramdevries93,

When did you create your hostname and DNS record? Usually, the propagation can take up to 24 hours so this behavior is expected at first.

Additionally, you’ll need to have a reverse DNS setup as well as this might slow you down. My best solution would be to use the IP address of your Droplet, unless of course you need SSL for some reason where the IP won’t be suitable.

Regards, KFSys