Question

Slow connection when using private hostname

Posted January 11, 2021 452 views
PHPNetworkingDigitalOcean Managed MySQL Database

Current setup:

  • MySQL Managed Database.
  • Droplet with our web server (nginx + php-fpm).

Both servers are hosted in the same network.

We recently ran into a problem when using a Managed MySQL database in a PHP application that is under higher load (200-300 requests / minute). Initially the requests were quiet fast but when the load increased the application became slower. We were able to trace this back to the part where we connect to our database using the private hostname.

Our problem appears to be fixed once we switched to using the private IP instead of the hostname. We suspected that there is some DNS resolution going on that caused the delay.

I’m wondering if this is a known issue and if there is a better way to fix it? For our Redis server we had a similar issue that was solved once we added the private IP and hostname to /etc/hosts.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Hi @bramdevries93,

When did you create your hostname and DNS record? Usually, the propagation can take up to 24 hours so this behavior is expected at first.

Additionally, you’ll need to have a reverse DNS setup as well as this might slow you down. My best solution would be to use the IP address of your Droplet, unless of course you need SSL for some reason where the IP won’t be suitable.

Regards,
KFSys

  • When did you create your hostname and DNS record? Usually, the propagation can take up to 24 hours so this behavior is expected at first.

    The database (and the hostname) was created last week, so 24 hours had passed at the time.

    Additionally, you’ll need to have a reverse DNS setup as well as this might slow you down. My best solution would be to use the IP address of your Droplet, unless of course you need SSL for some reason where the IP won’t be suitable.

    I’m not entirely sure how this would solve the problem? If you meant that we should add the private IP address and the private hostname to the /etc/hosts file on our Droplet then that is was what we did. I’m just wondering if there are any downsides to doing this (what if the private IP changes, does it work for our standby node?)

    Our expectation with using managed databases was this this is not necessary.

    • Hi there, this is exactly the same situation I’ve just encountered. I’m using Laravel and if I use the hostname like

      DB_HOST=private-hostname

      ab is returning very bad performance, around 8 requests / second.

      If I change to:

      DB_HOST=private-ip (I’ve found the IP by doing host private-hostname)

      The performance are much better, around 80 requests / second.

      I’m really not sure why this happens but I’m concerned of using the private IP because the customer support told me that in case of an outage, the managed database is replaced with another node and the IP might change, that’s why they provide an hostname.

      Have you encountered any issue and/or a viable solution?

i have the same problem with digitalocean manage dababase. and make me lot of problem and spend my time.

jus add private db host name in /etc/hosts
we get 10x speed.

ab -n 1000 -n 100 https://xxxx.xxxx.com/luke/
without setting db hosts in local
take:5.762 seconds

with setting db hosts in local
Take:0.6 seconds