Question

Slow to connect to droplet through ssh or ftp

Three to four months ago connecting to my droplet through ssh took about a second. Then suddenly it takes from a minute to two before I’m prompted for the password. And then about the same time to get to the command line in my centos droplet.

Sam goes for an ftp connection. A minute to connect and list the files. Another minute for connection is established to upload a file. Then the file upload it self isn’t too bad. But still, waiting two minutes to connect isn’t cool.

I’m on the cheapest package. But I find it weird that it was quick and then quite a substantial drop in speed.

Is this a know problem? Is it something that can be fixed? Or do I need to upgrade to a more expensive package for quicker connections? Mind you that its only connection that is the problem. The initial connect.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Try this:

  1. Edit the ssh config nano /etc/ssh/sshd_config

  2. Disable “use dns” option useDNS yes # CHANGE THIS TO no

  3. Save and close ctrl + X, Y, enter

  4. Restart the sshd service service sshd restart

Thanks! Helped me…

For those who are interested: useDNS no is now the default setting

We don’t modify this in Debian/Ubuntu. The default was changed to “UseDNS no” in OpenSSH 6.8p1, which is in Ubuntu 15.10 and later. https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/424371

And an explanation of its use can be found at: http://unix.stackexchange.com/questions/56941/what-is-the-point-of-sshd-usedns-option/56947

TLDR;

The UseDNS option is mostly useless.

- if you dont have that option, just add anywhere
# option use DNS
useDNS no
- after that restart
service sshd restart
- if not available 
service ssh restart
- try log in again