Sourcefabric Booktype (Book Collab Software)?

Posted January 5, 2015 8.3k views

Hello all.

I just wonder if any of you have tried to install Sourcefabric Booktype (or other of their software) on a virtual server?

Her is Booktype:


I would really like to get Booktype working on my server, but I am a newbie linux/server admin, thus I don’t want to mess up my droplet server setup.

Anyone want to test this Booktype in a virtual host?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
20 answers

Hi, I wrote the documentation linked above, I’d be happy to help. Booktype will run on a standard Python 2.7 setup, including virtual servers. Personally, I use VirtualBox OSE from to create Debian and Ubuntu instances for testing.

Before installing a Booktype 2.0 snapshot I would recommend that you create a login on the development server which will give you an impression of the current state of Booktype 2.0.

  • Hello Daniel, thanks for your comment. Good to see some of you sourcefabric guys in here. I really like your software and your ideas, actually I am now watching this one:

    Book Collab and your other projects are part of the future for sure.

    I know I will be able to set up booktype in a test server using VirtualBox, but I am probably too newbie to be able to get virtualmin working in a local testenvironment to be able to test booktype in a VIRTUAL HOST setting.

    In order to have virtualmin working I probably need to be on my live server (droplet), and I am affraid I may risk destroying some of my current setup if I try install BookType on my live server.

    I know I can make snapshots of the working server, and revert to the snapshot if something goes wrong, but many things can go wrong without me knowing or discovering it, errors may show up later, so I would really hope some more experienced people test this out first.

    Have you tried it in a virtualmin setting, on Ubuntu 14.04 server?

Hi, if you are not confident with Python I would not recommend installing Booktype on your live server for now. I understand that virtualmin is like webmin for virtual servers, but I have not personally tried installing Booktype in that environment. Our current Booktype installation instructions cover the Debian/Ubuntu way of configuring services.

I’m planning to write a tutorial on installing Booktype on a droplet, at some point, but I’d be inclined to do that without the use of a hosting control panel. My reasoning is that users who need such a panel would have fewer headaches if they bought a managed hosting service :-)

If you have the time available and would like to learn for yourself, what I’d recommend is that you install VirtualBox on your local desktop computer, create something like a Debian stable (wheezy) instance on it, and get familiar with how to install programs like Booktype via the shell.

You are not doing anything wrong :-) This error is just because Booktype 2.0 has not been released yet. In the meantime, you can get the daily snapshots from and install them with any package manager that supports dependency resolution, for example using gdebi and today’s snapshot:

sudo apt-get install gdebi-core
sudo gdebi booktype2.0.0~20150107-1all.deb

Let us know how you get on! You will probably need to put the Virtualbox ethernet interfaces into bridged mode so that the test servers can get a real IP address on your local network, for example by DHCP. That makes it easier to interact with the servers using your desktop machine as if it was a remote client.

Booktype 2.0 requires Redis server 2.8 or later, a version which is available in Ubuntu 14.04 LTS ‘Trusty’ but is not currently available in Debian 7 'wheezy’. If your Debian server runs wheezy, make sure you have the wheezy-backports apt repository set up. There should be a line similar to:

deb wheezy-backports main

in your /etc/apt/sources.list file. If you need to add a line for wheezy-backports, you can find a list of mirror sites at

What happens if you do this (as root)?

apt-get update
apt-cache show redis-server

It should show you that both 2.4.14 and 2.8.17 are available. Then the command:

apt-get install redis-server

should install the 2.8 version for you.

If you have built your own copy of redis from source, the Debian package manager will not know about that, it only tracks .deb packages. You probably have two copies of redis installed now :-)

The command:

dpkg-query -l redis-server

should return the Debian package version installed, which should be 2.8.17-1~bpo70+1+b1

If that is the case, please try running this command again:

sudo gdebi booktype2.0.0~20150107-1all.deb

That works for me on wheezy. If it still doesn’t work, we need to dig deeper…

I understand what you are saying, but short term pain is long term gain. I am familiar with installing programs using the shell, so need no graphic control panel if I have to manage without. I am learning as I go. Rather learn something useful than buy managed hosting :-) Beside I am planning a project with so many users that I can not afford SourceFabrics prices.

I will follow your advice and try installing this thing in local virtualboxed testserver :-)


I have set up testservers (UbuntuServer 14.04 and Debian 7 64bit) in Virtualbox, internet access.

I have followed the installguide here

When I have done everything from top of guide and come to type in the following command:
sudo apt-get install booktype (or apt-get install booktype in Debian) i get the following result:

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package booktype

I get the same error both in Ubuntu and Debian at the same place, so what could I be doing wrong here? Or is it something missing in the install guide?

Thank you Daniel.

I used wget to download the snapshot, then:

root@debian:~# gdebi booktype2.0.0~20150107-1all.deb
Reading package lists… Done
Building dependency tree
Reading state information… Done
Building data structures… Done
Building data structures… Done
This package is uninstallable
Dependency is not satisfiable: redis-server (>= 2:2.8)


I have followed the tutorial, so I assume I have the latest redis-server?

Running bridged mode on my boxes btw :-)

Hmm…I did what you said…followed the tutorial


deb wheezy-backports main

to /etc/apt/sources.list file

so this was in place before I wrote the above comment reporting the error about redis server.

So, I guess I need to find another way to get the correct redis-server, so what do I need to do?

Previous 1 2 Next