Question

Spaces: connection not secure when accessing public object via HTTPS

  • Posted on February 10, 2022
  • SandyAquamarineUrchinAsked by info

In Spaces, when accessing a public object (e.g. PDF file) externally via HTTPS, there seems to be an issue with the certificate… Chrome displays the following message -

Your connection is not private Attackers might be trying to steal your information from craton.capital.fra1.digitaloceanspaces.com (for example, passwords, messages, or credit cards). Learn more NET::ERR_CERT_COMMON_NAME_INVALID

I tried on several computers in different geographic location - same result. Is there a way to fix this?


Submit an answer


This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

I think I figured it out… don’t use a dot in the space name. Without a dot seems to be fine.

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel