Question

Spaces: copyObject fails for keys with special characters

I am trying to use the S3’s copyObject API on DO Spaces. However, this is failing if the source file has special characters like ‘?’. I am using aws-js-sdk. The requests fail with ‘NoSuchKey’.

Request ID of one such failing request is tx0000000000000e06c9cb0-005d379c1b-23e283-sfo2a. I am trying to copy a file named ‘whatever?’. I have tried percent encoding as well but that doesn’t help. FWIW, our code works on S3 itself.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Thanks @MattIPv4 I will ask there.

Hi there @girishcloudron,

Hm, this is an interesting one!

I’m not quite sure what is going on here, I think it’d be best if you could get in touch with our amazing support team. They can work with you to establish the source of the issue and get it solved for you!

https://www.digitalocean.com/company/contact/#support

Hope that helps! - Matt.