Question

Spaces CORS configuration for localhost not working. (I used the s3cmd)

Hello,

I have configured my CORS policy by using s3cmd. My configuration in Control Panel seems to be ok. I have set an

My CORS Options shown in Control Panel Origin: http://localhost:4000 Allowed Methods:GET PUT DELETE POST HEAD Allowed Headers: *

However I still get an error that my request has been blocked by cors policy. Could you please tell me how to setup it correctly so I would be able to test my environment and spaces by using localhost:4000??

The response:

Access to XMLHttpRequest at ‘https://fra1.digitaloceanspaces.com/’ from origin ‘http://localhost:4000’ has been blocked by CORS policy: Response to preflight request doesn’t pass access control check: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.

GET https://fra1.digitaloceanspaces.com/ net::ERR_FAILED


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@mateuszwasielewski13 I just had the same problem. Try setting origin to *