I’m building a client application that uploads directly to spaces with a presigned URL. It gets a presigned putObject URL to upload the file. I can manually send the PUT request from cURL, which succeeds, but in the browser it rejects the PUT response for not having an access-control-allow-origin header set.

My cors configuration is set to
AllowedOrigins: *
AllowedMethods: GET, PUT
AllowedHeaders: *

Is there something I’m missing to have Spaces respond with the access-control-allow-origin header? Or is it not possible?

1 comment
  • Thought I should add that the OPTIONS request works, and has the access-control-allow-origin header set properly, but the header is missing from the PUT response.

Submit an answer

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!