Question

sql_mode=only_full_group_by

I have an ubuntu 18.04 connected with a shared mysql, both fresh installations. Yesterday I transfered the website and everything looked fine so far. This morning I realised that the search function is not working at all on wp-admin. Check the errors and I got this

WordPress database error Expression #10 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'dbname.lt.name' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by for query 

Any ideas as the mysql server is shared and I can’t change that.

Thanks G.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

To solve this on the DO MySQL Cloud DBs, we added the following to the MySQL 8 SQL mode defaults:

ANSI (Shorthand) ERROR_FOR_DIVISION_BY_ZERO NO_ENGINE_SUBSTITUTION NO_ZERO_DATE NO_ZERO_IN_DATE STRICT_ALL_TABLES STRICT_TRANS_TABLES

If anyone is still having this issue on droplets, please check this out. It will solve it. HERE

Hi all,

now we dont need any custom code on function or wherever else. You can easily control these options from database dashboard on DO admin panel.

Here you got all information. https://www.digitalocean.com/docs/databases/mysql/how-to/set-sql-mode/

Thanks, Giorgos