Question

SSDP communication not working between VMs

Just trying to make an app which can discover other instances of itself over the network.

Was trying to run ssdpy python package quick start example. I run the following command in one machine:

$ ssdpy-server my-special-service --location 'http://10.0.0.1:8080/hello'

Then I run the listener command from another machine:

$ ssdpy-discover ssdp:all 

The above command does not list anything. There are no execution errors.

However on running both server and client on the same machine works. It is some networking/standards issue; but can’t figure what is the issue.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there,

In case both of your servers are running in the same VPC, I would recommend changing the address from 10.0.0.1 to match your actual server private IP address.

Then to check if the service is actually listening on that port, you could run the following command:

netstat -plant | grep 8080

Let me know how it goes. Best, Bobby