Question

SSH connection timed out. Cannot login

Hello, I just starded using DigitalOcean. I have created Ubuntu droplet for wordpres LAMP eviroment. From the beginning i was using Putty with SSH pair (set up public key on droplet creation) I have fallowed all the guides, and configured everything proprely and everything is running. But I no longer can login trough putty of filezilla sftp. Network error connnection timed out. I have restarded my PC as win10 has its moods but that didint help. Tried to login trough web inteface but console ask me for basic login credentials insted of key!

Whats going on? Help plz


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Sorry for above comment

Finally, I got it !!

It was the issue with the firewall

these commands solved my issue.

sudo ufw default deny incoming sudo ufw default allow outgoing sudo ufw allow ssh sudo ufw allow 22

I am also facing the same issue. I tried resetting password also but no use. On putty not even allowed putting username then what is the use with reset password? Other droplets are working fine though.

For console access have you tried “Reset Root Password” (under the “Launch Console” button)? Will email you password to access console as root. May take a few minutes to get the email.