A1e41d137c432dba7608e358b0fb575f51ba9c2d
By:
Maqbool

ssh is very slow it delay while using on the terminal its not fast how can i solve

January 20, 2015 9.3k views

****ssh connection delay in the command it not as snappy as working on machine locally how can i solve this issue delaying in command typing and result like delay of 2 seconds

8 comments
  • If you ping your Droplet from your local machine, what respone times do you get then? Any packetloss?

  • Any update on this? I'm also in the same situation. Typing on SSH console is really unresponsive.

  • I'm having the same issue. Still no answer?

  • @javierluz That doesn't seem to solve the lagging issue. I tried it but didn't notice any difference. Please somebody at DigitalOcean should raise their voice here. It's a very disappointing performance.

  • I'm having the same problem, connecting through ssh will frequently get lags that are completely disruptive to doing coding on the terminal. There is no reason that even the single core 512MB configuration should experience this, and if this problem persists, it is certainly a deal breaker as I pretty much exclusively use command line and vi for everything I do.

  • @johnmbillings exactly, i was having that kind of issue but when i switch my droplet from New York to Singapore everything working smooth.

  • I took a snapshot of the droplet (Newyork region), changed its region to Singapore. And created a new droplet from this image with Singapore region. Now its faster. For the issue was with datacenter and not with my application.

2 Answers

There seems to be a problem with one/some of the New York data centers. I was on NY3 and was experiencing major lag in the terminal. I switched to SF2 (San Francisco), and the problem is solved.

Have another answer? Share your knowledge.