Question

SSH issue for newly created droplets

  • Posted February 22, 2015

I created my first CoreOS droplet, put my ssh public key there.

When I went to Console Access from my account, it asked for login, entered root, then it asked for password. I don’t have a password because I created the droplet with SSH key.

Same thing happened when trying to ssh from my local machine.

I even tried to destroy and recreate the droplet, but it doesn’t help.

Any thought?

Thanks.

DD

Subscribe
Share

If this was the first time you tried to access your droplet, try to enter the password you received in an email after you signed up. It will ask you to reset your password to whatever you like. At this point you should create a new user with “root” privileges for which you will create an SSH key. It seems like a lot but it is easy.

Same issue here - thought I’d try setting up a new droplet with just my SSH keys and no password. First login needed ssh root@IPADDRESS but requested no password, so I suppose my SSH keys are doing their job…


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello, there

As per the other comments, the user should be "core"and not “root”

You can ssh to the droplet with the following command:

  1. ssh core@DropletIP

If you want to specify the ssh-key you can also use the -iargument:

  1. ssh -i ~/.ssh/ssh-key core@DropletIP

Regards, Alex

solved

my bad, the default user for coreOS is core, not root