Question

ssh login with key for user other than root

  • Posted December 2, 2014

I followed the process in https://www.digitalocean.com/community/tutorials/how-to-configure-ssh-key-based-authentication-on-a-linux-server to set up ssh login for a user account (not root). I installed a new key pair (call it new_key_pair) and executed ssh -i new_key_pair user@xxx.xxx.xxx.xxx and still was asked for the user’s password. CentOS install and have installed public part of key in /home/user/.ssh/authorized_keys with proper permissions.
What am I missing? thanks

Subscribe
Share

Thanks. Made the change in the ssh_config file, restarted ssh and now get the following error message when attempting to ssh as user (using either the root key or the key I created for the user): Permission denied (publickey,gssapi-keyex,gssapi-with-mic).

When this up did you turn off password authentication in your sshd_config?

PasswordAuthentication no

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

on MacOS for a successful login into your droplet you need to add the key to key chain

```ssh-add -K /Path/To/Your/Keyfile```