Question

SSH okay via PuTTy - Unable to SFTP

Posted March 25, 2016 3k views
Ubuntu WordPress DigitalOcean

After setting up my droplet and installing Wordpress, I need to get the SFTP working through WP as well as FileZilla.

Whenever I start up PuTTy to connect to the droplet, it does not ask for a password as the SSH keys appear to be working fine.

I’m able to run commands, etc. via the PuTTy shell.

However, I am not able to access my droplet via SFTP, although I’m using the correct User and Password that gives me Sudo access. I left the port at 22 for now.

Within FileZilla, after running Tail, it says “No supported authentication methods available.” I don’t under this. The SSH keys appear to be working and I can access easily via PuTTy, but not using my FTP application (set for SFTP port 22).

Any ideas?
TIA

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

1 answer

Sounds like you disabled password authentication.

  • Just to add a further comment, WinSCP provides a means to specify a private key . Generally, I would say it would be more preferable than enabling password authentication.

    • At this point I’m trying to get the SSH part to work. It works fine when I log in with my username in puTTY, with the keys being acknowledged and no password required.

      But the username setup for wordpress (wp-user) for the purpose of server access via SSH does not work. I’ve created a new thread on this and am abandoning the FTP, FTPS, and trying to get SSH2 going.

      I’ve created a different thread for that.

      Thanks for replies.

  • I wouldn’t doubt it. Went through so many instruction pages to do this, do that, I could easily have done that. At the moment I have no idea what file that little tidbit happens to be in. Moved off of trying FTP/SFTP and trying to get Wordpress to accept SSH.

    Thanks.

Submit an Answer