Question

SSH to localhost gets timeout

  • Posted November 9, 2014

So I’m giving up searching for solution and simply ask. Quite sure it’s an very easy fix but and I’m new to admin a server

Basically - I cannot connect localhost / 127.0.0.1 via SSH

ping localhost

PING localhost (127.0.0.1) 56(84) bytes of data. 64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.046 ms 64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.092 ms 64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.086 ms 64 bytes from localhost (127.0.0.1): icmp_seq=4 ttl=64 time=0.090 ms 64 bytes from localhost (127.0.0.1): icmp_seq=5 ttl=64 time=0.140 ms 64 bytes from localhost (127.0.0.1): icmp_seq=6 ttl=64 time=0.064 ms ^C — localhost ping statistics — 6 packets transmitted, 6 received, 0% packet loss, time 4998ms rtt min/avg/max/mdev = 0.046/0.086/0.140/0.030 ms

traceroute localhost

traceroute to localhost (127.0.0.1), 30 hops max, 60 byte packets 1 * * * 2 * * * 3 * * * 4 * * * 5 * * * … 25 * * * 26 * * * 27 * * * 28 * * * 29 * * * 30 * * *

ssh -vvv localhost

OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug2: ssh_connect: needpriv 0 debug1: Connecting to localhost [127.0.0.1] port 22. debug1: connect to address 127.0.0.1 port 22: Connection timed out ssh: connect to host localhost port 22: Connection timed out

So where do I start the search for the solution?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Configure your firewall to allow it.