ssh with domain name instead of ip of droplet

August 1, 2014 3.4k views

Can I add my domain name to the droplets /etc/hosts file?
127.0.0.1 mydomain.com

so I can ssh into it with the domain name instead of using the ip:
-> ssh root@mydomain.com

1 comment
  • my mistake.
    The first time I used my domain name with ssh. I got a prompt saying 'mydomain.com' could not be authenticated ... proceed' (or something to that effect.
    I just canceld and starting mucking with the /etc/hosts/.

    It turns out that just saying go ahead to the ' could not be authenticated' and I connect.
    Subsequent ssh just work work and I've not seen the 'could not be ' message again.
    no need to add anything to the /etc/hosts/.

2 Answers

You need to point to the droplet's IP address with DNS. Adding the domain name to /etc/hosts will not allow other machines on the internet to query for the IP.

  • My domain name IS registered with DNS and works fine with my droplet.

  • If your DNS works fine, then the command you gave us above works fine as well and there's no need to modify the hosts file.

Hi there, I'm hoping someone can help me. I am trying to access a droplet in the same way described by the OP - ssh via the domain instead of the IP address of the droplet.

I am running LAMP on Ubuntu 14.04 in the droplet and I have CloudFlare set up managing my DNS records for the domain.

When I run "ssh root@domain.com" I get the error "ssh: connect to host domain.com port 22: No route to host"

I haven't made any changes to the server since setting up the droplet and I'm (obviously!) not particularly knowledgable with server set up, am I missing something in the basic set up of the server that allows this? Any insight would be appreciated :)

Have another answer? Share your knowledge.