Question

ssh_exchange_identification: read: Operation timed out

I usually connect to any droplet using ssh and works normally. Somehow it stopped working and I keep getting the following error: ssh_exchange_identification: read: Operation timed out Any idea what caused this issue?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

@majidhassan @getsavi16 I managed to access the droplet but this is not a final fix so this may help you until the issue is solved.

  1. Reset droplet root password
  2. Use Opera Developer version and enabling VPN
  3. Login to digitalocean and open the droplet’s console access
  4. Login using username and the password sent by email.

The console works perfectly without any lagging

Same problem here in Egypt, I have tried a couple of different ISPs but in vain

Welcome to Egypt !

Same issue here, Was working fine past week then stopped then worked again, and now stopped again :)

Egypt seems to be blocking some of the data-centers for DO. Take a snapshot of your server, and deploy it in a different region. I tried Singapore and it worked fine.

@omarsafwany Good to know that that’s one possible solution.

I talked to TE Data today. They’re my current ISP and they control Egypt’s Internet backbone as I understand it. They are experiencing some outages with certain services. Not sure if this is related or not, but thought I’d share.

Also, I managed to work around the issue by SSHing into a DO droplet that’s working fine for me and then SSHing from that droplet into the otherwise problematic one. Again not a comfortable final solution but works for now.

Bumping this guys. I’m in Egypt as well and getting the exact same issue. Anyone make any progress on this?

@majidhassan Yes I am in Egypt. The issue occurred again and till now it’s not working. :/

@omarsafwany It turned out it’s an issue with my ISP :/ are you by any chance also in Egypt? :D

@majidhassan It just went back working the next day without doing anything else. But I really could not figure out the cause of such problem.

I have the same issue. My machine was working fine, then suddenly I started getting this error. Also, any newly spawned droplets have the same issue for some reason.

I tried @gndo’s suggestions, checking whether I had any overload, I didn’t but resized the droplet anyways. I’m trying to connect using the console, but that isn’t working either.

@omarsafwany I’m curious, what your fix/problem was after all.